First Aid

First Aid training, for most organisations, will be a mandatory requirement. The level of training required, and the number of people that should be trained, is affected by a number of factors, such as the number of people on any given site and the level of risk posed by activity there.

 

As an absolute minimum, all workplaces should have an “Appointed Person” that is responsible for ensuring the upkeep and stocking of the on-site First Aid kit.

 

Loading Events

Upcoming Events › First Aid

Events Search and Views Navigation

Event Views Navigation

October 2019

Plymouth | FAW (3 Day)

October 14 @ 08:30 - October 16 @ 16:30
Plymouth, Backline Logistics, Unit 1 Alder Court, Bell Close
Plympton, Devon PL7 4JH
£265 11 tickets left

Ofqual accredited First Aid training from Backline Logistics. Includes FREE Driver CPC hours when you book online!

Find out more »

Exeter | EFAW – 1 Day

October 28 @ 08:30 - 16:30
Exeter Outbase, Backline Logistics, Mushroom Road, Hill Barton Business Park
Exeter, Devon EX5 1DR United Kingdom
£100 12 tickets left

Ofqual accredited First Aid training from Backline Logistics. Includes FREE Driver CPC hours when you book online!

Find out more »

November 2019

Yeovil | EFAW – 1 Day

November 4 @ 08:30 - 16:30
Yeovil, Backline Logistics, Unit 2 Plot 13, Brympton Way, Lynx West Ind. Est.
Yeovil, Somerset BA20 2HP United Kingdom
£100 12 tickets left

Ofqual accredited First Aid training from Backline Logistics. Includes FREE Driver CPC hours when you book online!

Find out more »
+ Export Events

What do we offer?

 

It’s useful to know that with our EFAW and FAW courses, Driver CPC hours can be included at no extra cost!

 

Emergency First Aid at Work (EFAW) | 1 Day | (FAA Level 3 Award)

First Aid at Work (FAW) | 3 day (Full) / 2 Day (Re-qual) | (FAA Level 3)

First Aid Risk Assessment | 1 day (FAA Level 2 Award)

Basic Life Support & AED Safe Use  | 4 hours (FAA Level 2 Award)

Appointed Person | 2 hours

 

Other courses are also available – please ask if the course you require is not listed.